Category Archives: Uncategorized

It shouldn’t be this hard!

Installing and checking points on a frequent basis is just part of the territory with mechanical distributors.  The thought of getting rid of this chore led me to decide to take advantage of IAP’s 15% off sale on electronic distributors and replace the original Marinelli unit.  It arrived yesterday and It’s a nice, solid device. I thought it should be relatively simple to install.

electronic distributor

It does not come with a mounting bracket so I took the old one off the stock unit (very tight fit, old and new).  This is where my first problems started.  There is no reference for the bracket relative to the distributor shaft.  The ignition timing with the electronic distributor is still set the same way, rotate the body and tighten down on the clamp nut, except instead of looking for the points to just open, you look at a small LED under the rotor to light up.  After what seemed like 100 attempts, I was finally able to get everything lined up and was ready to tighten down the clamp nut.

NOT!  With the old distributor I can loosen/tighten the nut with a simple 10mm socket on a long extension.  When I tried this with the new unit, I couldn’t get the socket over the nut due to interference from the body of the distributor.  I even have a special right angle 10mm box end wrench made just for this application, but it too was hitting the body and not able to get over the nut.

distributor comparison

That’s my special distributor wrench trying to get on the nut on the left.  The old distributor had lots of room under the head but the new unit has virtually none.  Sigh…

I had even gone out for a spin before trying to install the new unit so the engine would be all warmed up and start easily.  So much for that idea.  Tomorrow I will go out and try to find a right angle 10mm open end wrench.  I will probably have to grind it down, but the open end may fit under the new distributor body.

It shouldn’t be this hard!

Advertisement

New Wheels

I have been falling way behind in my Alfa blogging, but much has been happening.

I never really liked the “Turbina” rims that are stock on the 74 Spider, so a couple of months ago I purchased a set of used old school steel rims from Alfa Parts Exchange in Stockton.  When I called to inquire, they said they not only had them, but they were coming through Sonoma County and would deliver them for free.  It took about six weeks, but APE came through and dropped off the rims.  He wasn’t too sure what the donor car was, but they were exactly what I was looking for.  In addition, he had hub caps to match.

I took the rims to Vaider in Rohnert Park to be media blasted and powder coated.  I just got them back yesterday and couldn’t be happier.

new wheels1

The one in the lower left has the hub cap on but is still missing the center Alfa button (as are the other hub caps).  My plan is to purchase the centers from IAP and order a set of 165/R14 Vreedestien tires.  165/R14 is the stock tire size but no longer available except from classic car tire places.

SPICA clockwork

Once the car came back from Mike’s, it was a little hard to start, but ran great once it warmed up a little.  This is due to the fix for the Thermostatic Actuator (TA).  Here’s a pic of the topside of the fuel injection pump:

What you are looking at are the brains of the system.  At the bottom is the cold start solenoid that only actuates when the starter is running.  I think it just dumps as much gas as it can.  Above and to the right is my “new” TA.  It’s just an old TA with a bolt threaded into the top.  The stock TA uses expanding fluid in a tube from the block to press the same piston that the threaded bolt depresses.  When the engine is cold, the piston is released and the mixture is richened.  As it heats up, the piston gets depressed and the mixture leans out.  This is fine until the tube breaks and you are running rich all the time.

This is basically what was causing my idle to be 2000-3000 rpm.  Rebuilt TAs are available for $350 or so, but Mike had the alternative from another job and we decided to try it out.  The bolt is set to the hot setting, so cold starts take awhile.  Once just a little heat develops, however, it runs fine.

Above and right of the TA is the gas shut off solenoid and mixture setting valve (yes, combined!).  The shut off solenoid is for deceleration to avoid backfire.  Finally, the device with the lever arm is the barometric compensator that is adjustable for starting temperature.

So the entire SPICA injection pump is really a mechanical computer with several clever mechanical sensors.  Only the Italians!!

Ciao

 

It’s Back!!

Yes, it’s been two weeks since I took the Alfa in to Mikes Imports in Santa Rosa.  I was getting worried that Mike’s was a black hole, but not only is he an Alfa expert, he was able to diagnose my faulty Thermostatic Actuator and cobble together an alternative from old parts he had laying around.  That’s the kind of shop I wanted!

The end result is the car is now running pretty well, actually quite well.  I only drove home from the shop, but I could tell the idle was even and it easily ran up through the gears.  My TA was shot and Mike replaced it with a TA that had a bolt threaded into the top of an old actuator so a fixed setting could be established.  This will cause issues with cold starts, but was an excellent solution to get me back on the road.

Mike also went through the rest of the basic tune up stuff,  I’m happy to say he liked my static timing, but had lots of good suggestions for future changes, the number one being an electronic ignition instead of the points.

So, I’m a happy camper.  I found a shop I like and I have a reasonable driver to enjoy.  Life is good…

Speaking of SPICA

Alfa has used mechanical fuel injection since 1969.  The injection pump is made by SPICA and is like a little clockwork under the hood.  It has compensation for cold starting, barometric pressure, engine temp, and God know what else – all mechanical.  When it is adjusted properly, it is a masterpiece, but adjusting it takes skill and special tools.

This is all to say that the car is now in the shop getting the SPICA pump looked at.  I read all the books and was tempted to try fiddling with the pump, but decided it would be better to have someone with the experience and tools have a go at it.

It also give me a chance to evaluate the local foreign car shop, Mike’s Imports and Engines.  His shop has all the appearance of a classic auto repair shop, cars, engines, parts, etc. stored everywhere in various states of repair.  I also noticed that Mike has an Alfa key on the keychain hanging from his belt – good sign.

So, I’m anxiously waiting for his call saying it’s ready to pick up and enjoy…

Back on the road

I was beginning to feel like I had bought a new car and wasn’t getting to drive it because all I was doing was tearing it apart to fix little things.  But all that changed yesterday.  I had to cut off the seat belt to get at the bracket.  That let me get the passenger seat out and see the rust building under it (more on that later).

At that point I decided to just reassemble the console, set the idle air adjustment, and go for a ride.  As I was pulling out, I realized I couldn’t press the accelerator very far.  This was definitely not a problem driving home, so I began to suspect I was responsible for the throttle cable coming off the spool.  I parked it and after a little fiddling, the cable is back on the spool.

I drove into town and gassed it up.  Now that the idiot lights are working, I could even see the gas reserve light come on.  The engine runs well, but I still have a high idle (2000-3000) when it warms up.  I’m going to replace all the rubber hoses on the intake and see if that makes any difference.

The inside story

I really wanted to get rid of the radio (who needs radio when you can listen to the engine?) so I decided to tackle that while I wait for a new throttle cable.  One thing led to another and I now have most of the interior torn apart.  The radio is gone, the wiring tidied up, and the idiot lights are clean and working (at least the light will light, some sensors appear to not be working).

I knew I needed to replace the seats.  They are completely trashed and currently covered in a seat cover.  Since taking out the passenger seat would make getting the center console back in much easier, I started there.  Whoa!  The seat needs to be moved fully forward and backward to get to the screws that hold the seat to the rails.  I could move it back and remove the front screws, but I can’t move it forward nearly enough to get to the rear screws, part of the seat assembly interferes with the seat belt and bracket.

There is no way to move the seat any further forward without cutting the belt off.  My first attempts at doing that taught me how tough seat belt fabric really is!  Stay tuned…

Hey, that’s not right!

On the way home from my test drive I noticed that once it warmed up, the idle was floating between 2000 and 3000 rpm.  I thought I might have left off an air hose or something and removed the air box to take a look.  As I did, I could see that the idle air adjust screw was completely loose and turning freely.  Simple, I thought.

But then I took a closer look at the throttle mechanism and noticed that the throttle cable isn’t properly wrapping on the spool

It’s winding up on the wrong side and fraying where it crosses.  I then got to looking at the cable assembly and it’s clear that this entire area has been tweaked and needs work.  I think just adjusting the idle air would fix it for now, but that cable is going to break at some point.

And we have ignition…

After a little archeological work to locate and identify the timing marks (jacked up one side and crawled under so I could lick the crank pulley clean and see the marks – okay, steel wool, no licking).  I realized I had used the TDC mark yesterday, not the static timing mark.

So, one more pass through the static timing procedure and it was time to turn the key.  FIRST CRANK IT FIRES!  Starts right up and sounds pretty good.  I let it run for a minute and shut it down to check for oil, etc.  No signs of trouble, so the top goes down and out I go for my first test ride.

I immediately notice that even cold, it has much, much more power than on the drive home.  I keep the revs down until it warms up a bit, then try running it up to 5000 rpm.  I wish I had recorded the sounds, true Italian.  Plus, very smooth, no misses, no backfire on deceleration – pretty much like I remember my ’69 Duetto.

I feel great!  Not only do I have a pure bred Italian spider, I had a great time proving to myself that I still know how to tune a car.

Getting there…

I’m no newbie when it comes to wrenching.  Back in the day I did everything myself, including engine rebuilds.  Recently, however, I’ve done less and less.  Today I spent the entire day rearranging my shop for auto repair and installing the tune up parts in the Alfa.  Any day wrenching is better than sitting in a conference room, but my back hurts!  My hands are covered in the kind of grime that has to wear off, it won’t wash off.  I’m cross-eyed from trying to see what the heck I’m doing under the hood.  And, I can’t wait to get back to it!

Everything went back in as expected, no major hitches.  I even took a shot at cleaning the cam cover, but it still needs more work.  Still, it looks nice with the new wires and coil.  The distributor cap is a replacement, not Marelli unfortunately.  I like the old school Marelli red caps.

So, it’s time to set the timing and fire it up!  All the manuals say set the static timing to 8 degrees ATDC.  I had already positioned the crank so the number one cylinder was at TDC, so I figured it would be simple to see the timing marks on the crank pully.  Can you see any marks there? 

Neither could I.  I threaded my arm down there and tried to clean off as much grime as I could.  I found the pointer and could see a couple of colored lines in the pulley that I assumed were the TDC and Static timing marks.  I did my best to lock down the distributor at the static mark and took a deep breath.  It was time to try firing it up.

I gently turned the key and fed in a little throttle.  Cough, sputter, cough.  Hey!  It fired once or twice!  That’s more than it had done since I parked after driving home.  Unfortunately, that’s all I was able to do, get it to fire once or twice.  I’m assuming it’s a simple matter of the timing being off and I can address that tomorrow.  Stay tuned.